Chrome 49 not showing the charts correctly


« Back to message list

Enter your email address to get email updates on this topic. You can stop receiving updates by clicking the link in the update email messages.

Posted by Erik Eversteyn on 27th March 2016
Afte uptating to chrome version 49.0.2623.108 some graphs are no lnger working correctly. No or incomplete data is shown.

As an example the 'radar-non-filled' demo (www.rgraph.net/demos/radar-non-filled.html) is not showing the graph info. When using Chrome 48.0.2564.97 the graph is correct.

Does anyone have the same problem?


Posted by Richard on 27th March 2016
Hi,

I've just updated my version of Chrome to the same and there are no problems with either that chart or others that I've checked on the site.

Do you get any errors shown in you JavaScript console? And do other browsers (eg Opera, Firefox, IE etc) still look OK?

You could see if you can update Chrome again FWIW but I'm now on the same version so I doubt that there's any value in that.

I doubt this will be significant, but what does this chart look like?

www.rgraph.net/tests/accessible-text/

It's using the latest code I have and the new accessible text feature.




Richard
Posted by Erik E. on 27th March 2016
Posted by Richard on 27th March 2016
Hi,

Don't know what to suggest I'm afraid - if you have Chrome Canary you could see how it appears in that. If you need to install it, I have it on my PC and it doesn't interfere with the regular Chrome installation.

As for the language version - I don't know if that would affect it and I don't how you would get/install the English version.

You could report it as a bug to Google but it will/would take time to be fixed.

Oh and I suppose you could also try other canvas based apps and see if they have problems.




Richard
Posted by Erik E on 29th March 2016
Hi Richard,

Chrome Canary (ver 51.0.2692.0) + Windows 7 (the os that I use) has the same problem.

Tested the demo graph on an other PC with Chrome 49 and Windows 10, everything works fine.

I found a simalar reaction on the internet (Chrome 49 + canvas + Windows 7):
- stackoverflow.com/questions/36026145/html5-canvas-clip-doesnt-work-in-chrome-when-rotation-is-applied
- stackoverflow.com/questions/36175526/canvas-not-rendering-image-it-used-to?noredirect=1#comment59989234_36175526

And an ealier solved bug in Chrome ver. 29:
- canvasjs.com/forums/topic/chart-is-not-visible-in-google-chrome/
- bugs.chromium.org/p/chromium/issues/detail?id=278940

The problem seems to be related to the browser hardware acceleration. When I turn off the 'hardware acceleration' in Chrome 49, everything works fine.

Maybe you can do something with this information.

Erik.

Posted by Richard on 29th March 2016
Hi,

Does this replicate your problem? It creates an image object in script instead of referencing a DOM node.

www.rgraph.net/fiddle/view.html/a-canvas-bug




Richard
Posted by Erik E. on 29th March 2016
Hi,

No, the result are the same in Chrome 49 with and without 'hardware acceleration', Chrome Canary 51, Chrome ver 48, FireFox and IE. No difference.

Erik.
Posted by Erik E. on 1st June 2016
Chrome updated to version 51.0.2704.63 and the problem is solved.
Graphs working again as before????

Erik.
Posted by Richard on 1st June 2016
Hi there,

Ok! I'm still using v50 and they look fine too. I guess it was a temporary glitch.



Richard

   Twitter: www.twitter.com/_rgraph
  Facebook: www.facebook.com/rgraph

PLEASE READ:

If RGraph has helped you please give your feedback - thanks! You can give your feedback or leave a testimonial by adding a forum post or clicking on the speech bubble icon at the very top right.

But most of all: Please link to the RGraph website! (get information by clicking on the chain icon at the top right of the page)

Add a reply

 




« Back to message list
RGraph on social media