Gantt chart background has changed

Share RGraph:   To help my Google visibility (it can't get much worse!), if you like and use RGraph I'd appreciate it if you could link to me

« Back to message list

Enter your email address to get email updates on this topic. You can stop receiving updates by clicking the link in the update email messages.

Posted by Philip Wiggins on 1st October 2015
With the new update the grid color has changed the background color.

www.dropbox.com/s/ql5t01s1ynuf3yz/Screenshot%202015-10-01%2008.51.46.png?dl=0


I've tried adding chart.background.color: 'white' to get the background to the way it looked before, but it doesn't do anything, but if I change the below color, it changes the entire background and the grid as well.
 
            'chart.background.grid': true,
             'chart.background.grid.width': 1,
             'chart.background.grid.color': '#ddd',
Posted by Philip Wiggins on 1st October 2015
The grids aren't showing up either as well.
Posted by Richard on 1st October 2015
Hi,

Here's an example that uses the grid and has a white background color:

www.rgraph.net/fiddle/view.html/a-gantt-chart-with-horizontal-bars

Richard
If RGraph has helped you - please share the website and give your feedback - thanks! You can give your feedback or leave a testimonial by adding a forum post
Posted by Philip Wiggins on 1st October 2015
not sure what I'm doing wrong then this is my setup for the graph, but the above PNG is a screen shot of the result.

   var gantt = new RGraph.Gantt({
                             id: 'projects_graph',
                             data: graph_array,
                             options: {
                                 xmin: graph_min,
                                 xmax: graph_max,
                                 labels: display_labels,
                                 'background.grid.autofit.numhlines': numhlines,
                                 backgroundColor: 'white',
                                 tooltips: {
                                     self: labels_array,
                                     coords: {
                                         page: true
                                     }
                                 },
                                 gutter: {
                                     top: 50,
                                     right: 40,
                                     left: 200,
                                     bottom: 75
                                 },
                                 'labels.percent': true
                             }
                         }).draw();
Posted by Richard Heyes on 1st October 2015
Hi there,

If there's a high 'max' number there may be so many vertical grid lines that they merge together, so try this:

'background.grid.autofit.numvlines': 5,
'background.grid.autofit.numhlines': 6,
'background.color': 'white'



Richard
If RGraph has helped you - please share the website and give your feedback - thanks!
Posted by Philip Wiggins on 1st October 2015
That was the problem thanks!

Add a reply




« Back to message list