Pie issue in IE7/8 when we have one slice


« Back to message list

Enter your email address to get email updates on this topic. You can stop receiving updates by clicking the link in the update email messages.

Posted by Dan Lipsa on 21st February 2013
I have a pie with one slice that takes entire pie in IE7 and I get an empty chart. Chart is defined like this:

{
     "args": [[3]],
     "config": {
         "chart.shadow.blur": 15,
         "chart.labels.ingraph.specific": ["xx: 3"],
         "chart.key": ["xx: 3"],
         "chart.shadow.offsety": 0,
         "chart.labels.ingraph": true,
         "chart.shadow.offsetx": 0,
         "chart.strokestyle": "white",
         "chart.title": "xxx",
         "chart.exploded": 2,
         "chart.title.size": 14,
         "chart.linewidth": 1,
         "chart.title.bold": true,
         "chart.shadow": true,
         "chart.tooltips": ["xx: 3"]
     },
     "type": "Pie"
}

Thanks.
Posted by RGraph support on 21st February 2013
Hi there,

Ok this is fixed and will be part of the next release:

dev.rgraph.net/tests/2013-02-28/pie-ie7-one-segment.html

PS Could you link to the RGraph website - thanks.

Richard, RGraph Support

1 Year Priority Support now reduced to £299:
   www.rgraph.net/support
Posted by Dan Lipsa on 21st February 2013
Thanks for your fast response. The change is in RGraph.pie.js only?
Posted by RGraph support on 21st February 2013
Hi there,

Yes IIRC I believe that was the only file that I modified.

Richard, RGraph Support

1 Year Priority Support now reduced to £299:
   www.rgraph.net/support

Add a reply

 




« Back to message list
RGraph on social media