RGraph not working on Chrome 34 with disable accelerated 2D canvas disabled


« Back to message list

Enter your email address to get email updates on this topic. You can stop receiving updates by clicking the link in the update email messages.

Posted by Thomas Williams on 15th April 2014
We've been using Rgraph for a while now, and everything was working fine until Chrome 34 updated. Now I'm no longer able to see charts. Do you have any ideas that might help?
Posted by Richard on 15th April 2014
Hi there,

I'm using Chrome 34 myself and it shows charts fine. Check the JavaScript console for errors and try using either the window.onload or the jQuery ready event (and in those functions don't forget to use the var keyword when creatiing the charts):

window.onload = function (e)
{
     var bar = new RGraph.Bar('cvs', [4,3,8,6,9])
         .draw()
}

Or:

$(document).ready(function (e)
{
     var bar = new RGraph.Bar('cvs', [4,3,8,6,9])
         .draw()
})





Richard
www.rgraph.net
If RGraph has helped you - please share the website - thanks!
Posted by Thomas Williams on 15th April 2014
It's not the javascript. The weird thing is the code is all there. No Javascript errors in the console. What makes it really strange is that you can hover over the blank chart, and it will show the tooltips. It just doesn't render the canvas. And just to make things even more complicated, all of our users are remoting into a terminal server in Amazon's EC2 cloud.
Posted by Richard on 15th April 2014
Hi there,

Try posting a link and I'll see if it works in my Chrome (also 34).




Richard
www.rgraph.net
If RGraph has helped you - please share the website - thanks!
Posted by Thomas Williams on 15th April 2014
I can't post a link, its an internal website with confidential information. I know it's something strange with the way we are doing things. Thanks for you help.

Add a reply

 




« Back to message list
RGraph on social media