Scatter chart, xaxispos, center vs bottom


« Back to message list

Enter your email address to get email updates on this topic. You can stop receiving updates by clicking the link in the update email messages.

Posted by Tom on 20th March 2013
Hi;

Specifying graph.Set('chart.xaxispos', 'center'); in my scatter graph causes the chart.labels to disappear, yet 'bottom' works. Here are the two examples:

oldfartcoders.com/scatterBug/scatterCenter.html

and

oldfartcoders.com/scatterBug/scatterBottom.html

Thanks,

--Tom
Posted by RGraph support on 20th March 2013
Hi there,

1. Have you got a sufficiently large bottom gutter?
2. Are you sure you're specifying "center" without a typo?

dev.rgraph.net/tests/scatter/bubble.html

PS Could you link to the RGraph website - thanks.

Richard, RGraph Support

1 Year Priority Support now reduced to £299:
   www.rgraph.net/support
Posted by Tom on 20th March 2013
I doubled the size of the bottom gutter from 150 to 300 but got the same result. 'center' is spelled correctly. You can see from the two examples that the charts are identical except for graph.Set('chart.xaxispos', 'center'); and graph.Set('chart.xaxispos', 'bottom');.

xaxispos works correctly in line charts.

Thanks,

Tom
Posted by RGraph support on 20th March 2013
Hi there,

I've tried your page with the libraries on rgraph.net and it works - so try the current (or perhaps the next) beta.



Richard, RGraph Support

1 Year Priority Support now reduced to £299:
   www.rgraph.net/support

Add a reply

 




« Back to message list
RGraph on social media