Possible Scatter chart X tickmarks bug

Share RGraph:   Share or Like RGraph on Facebook!

« Back to message list

Enter your email address to get email updates on this topic. You can stop receiving updates by clicking the link in the update email messages.

Posted by Jens S. on 3rd February 2017
Possible bug: After upgrading to 4.60 tickmarks along the x axis (chart.xticks=true) disappeared in my scatter charts (canvas). More precisely they seem to have gone up to the top of the canvas, barely visible as single pixels.

Downgrading to 4.59 solved the problem.
Posted by Richard on 3rd February 2017
Hi there,

Can you post the source code that reproduces the bug?

Thanks.




Richard
Posted by Jens S. on 3rd February 2017
I had a bit of trouble creating code that actually failed. After cleaning my code in order to make a standalone example, it just worked. After a lot of experiments I finally found the parameter that made it fail.

If ymin is 0 it works. Positive values for ymin makes the xticks disappear.

If you take the code from www.rgraph.net/demos/scatter-basic.html and add "ymin: 5" to the parameters, it fails in v4.60.
Posted by Richard on 3rd February 2017
Hi,

Thanks, I'll take a look at it and hopefully get it fixed for the next version. If you're interested, the next version will have an SVG Scatter chart in addition to the canvas Scatter chart.





Richard
Posted by Jens S. on 3rd February 2017
Awesome, thanks
Posted by Richard on 3rd February 2017
Hi there,

Hopefully that should be fixed in the next release, be it beta or stable.




Richard

Add a reply




« Back to message list