AJAX caching in Internet Explorer


« Back to message list

Enter your email address to get email updates on this topic. You can stop receiving updates by clicking the link in the update email messages.

Posted by Antonio Vianello on 9th July 2013
Hi there!

I know there's a problem with Internet Explorer caching AJAX request so that, for example, my dynamic gauge chart shows always the data of the first AJAX call, while with Mozilla, Chrome and other I can see the values changing.

Is there a way to disable AJAX request caching in Explorer or tell RGraph not to cache the requests?

Thanks in advance
Posted by RGraph support on 9th July 2013
Hi there,

If there is then you'll probably find it in the options - try disabling caching entirely. You could also try appending some random query string data to your request URL like this:

/getData.html?468531523546

Or another - more involved - method would be to put the random string at the front of the request like this:

/468531523546-getData.html

And use URL rewriting to change the URL to getData.html. Though try the query string option first as it's easiest.





Richard, RGraph Support

5 developer license with Priority support for £299:
   www.rgraph.net/license#five-developer

Add a reply

 




« Back to message list
RGraph on social media