Disable Increase in size in the Pie chart RoundRobin effect

Share RGraph:   To help my Google visibility (it can't get much worse!), if you like and use RGraph I'd appreciate it if you could link to me

« Back to message list

Enter your email address to get email updates on this topic. You can stop receiving updates by clicking the link in the update email messages.

Posted by Andrew K on 12th March 2014
I'm looking to disable to increase in size feature on the RGraph.Effects.Pie.RoundRobin(pie) effect, having trouble finding this, been looking in the RGraph.common.effects.js file - thanks.
Posted by Richard on 13th March 2014
Hi there,


Use the radius option, like this:

RGraph.Effects.Pie.RoundRobin(obj, {radius: false});


Note that effects are changing in the NEXT version (RGraph3). So to use the RoundRobin effect you'll do this:

var obj = new RGraph.Pie('cvs', [4,8,6,3,5,2,1,6])
     .set('gutter.left', 35)
     .set('title', 'A Pie with the RoundRobin effect')
     .roundRobin({radius: false});




Richard
www.rgraph.net
If RGraph has helped you - please share the website - thanks!

Add a reply




« Back to message list