Line chart not being drawn correctly - safari issue


« Back to message list

Enter your email address to get email updates on this topic. You can stop receiving updates by clicking the link in the update email messages.

Posted by Arkadiy on 13th February 2014
Hi,

I try to load home page www.rgraph.net/
in Safari (Version 6.1.1 (8537.73.11)) under MAC OS X (Version 10.8.5 ).
The line chart on this page invisible and on mouse click on the chart all grids disappear.
The same issues are repeated with few examples:

www.rgraph.net/demos/line-adjustable-range.html
www.rgraph.net/demos/line-front-page.html
www.rgraph.net/demos/line-click-event.html
www.rgraph.net/demos/line-fan.html
www.rgraph.net/demos/line-axis-options.html
....

In demo.huihoo.com/rgraph/examples/line.html page the problems not appears (it seems not same version of RGraph which use in www.rgraph.net).

Best regards
Arkadiy
Posted by Richard on 13th February 2014
Hi there,

I don't have a Mac to test with I'm afraid - only Windows Safari 5.1 - where all the links that you gave work OK.

I would suggest that you try a basic chart - and then add the RGraph.common.dynamic.js script to the page (but not specifying any dynamic features to your chart) and see what that does.



Richard, RGraph Support
www.rgraph.net
Please link to the RGraph website
Posted by Arkadiy on 13th February 2014
Hi Richard,

In Windows Safari 5.1.7
----------------------------
  all work fine.



In Safari 6.1.1 (OS X)
----------------------------
After removing RGraph.common.dynamic.js issue with disappeared grid is fixed.
But main drawing line yet disappears. For example in html page below.

Same page work properly in Firefox 26.0 under same MAC OS X


"<!DOCTYPE html >
<html>
<head>
     <script src="./RGraph/RGraph.common.core.js" ></script>
     <script src="./RGraph/RGraph.line.js" ></script>
</head>
<body>
     <canvas id="cvs" width="600" height="250">[No canvas support]</canvas>
     <script>
         window.onload = function ()
         {
             var line = new RGraph.Line('cvs', [20,30,50,40,30,50,40,30,60,50,10,20])
                 .Set('labels', ['Jan','Feb','Mar','Apr','May','Jun','Jul','Aug','Sep','Oct','Nov','Dec'])
                 .Draw();
         }
     </script>
</body>
</html>"

Best regards
Arkadiy
Posted by Richard on 13th February 2014
Hi there,

Then maybe it's an issue specific to Safari 6 on Mac. Try Chrome and see how that fares.



Richard, RGraph Support
www.rgraph.net
Please link to the RGraph website
Posted by Arkadiy on 13th February 2014
In Chrome Version 32.0.1700.107 (same OS X) - all work fine.

Best regard
Arkadiy
Posted by Richard on 13th February 2014
Hi there,

Then maybe it's a Mac Safari specific issue.



Richard, RGraph Support
www.rgraph.net
Please link to the RGraph website
Posted by Arkadiy on 13th February 2014
Thank you!

Best regards
Arkadiy
Posted by Jamie Milnes on 27th February 2014
Hi Richard,

Its definitely not just a Mac / Safari 6.1.1 specific issue as your basic line demos are not working on Mac / Firefox 27.0.1

But its fine on Mac / Chrome 33.0.1750.117

Cheers,
Jamie

Add a reply

 




« Back to message list
RGraph on social media