When using ymin the zero does not appear

Share RGraph:   To help my Google visibility (it can't get much worse!), if you like and use RGraph I'd appreciate it if you could link to me

« Back to message list

Enter your email address to get email updates on this topic. You can stop receiving updates by clicking the link in the update email messages.

Posted by Toby on 3rd November 2013
Hello Richard

.Set('chart.ymin', 0)
In the y-axis is "0" does not appear. How can I do this?

Thanks for the help.

Cheers
Tobias
Posted by RGraph support on 4th November 2013
Hi there,

The easiest way would be to turn off the X axis - like the Line chart on the front page. But if you want that then you will need to use the Y axis drawing API object, of which there's an example here:

www.rgraph.net/demos/drawing-api-yaxis-basic.html


Richard, RGraph Support
Please remember to link to the RGraph website (or buy an RGraph
license and you don't need to!)

Single developer license just £199:
   www.rgraph.net/license#one-developer
Posted by Toby on 4th November 2013
Thanks for the reply.
Irritates me at the chart.ymin all values ​​are possible, except "0". Why is this so? Also off the x-axis does not help.

Cheers
Toby
Posted by RGraph Support on 4th November 2013
Hi there,

You may be able to set the ymin and ymax so that technically the ymin isn't zero, but because of the rounding effect it gets shown as zero,

www.rgraph.net/fiddle/view/a-filled-line-chart-with-a-scale-that-starts-at-zero



Richard, RGraph Support

Help support RGraph - single site license only £99
    www.rgraph.net/license#single-site
Posted by Toby on 5th November 2013
Hello Richard

Thank you for this trick. If I do ymin 0.01, values ​​are not marked with 0 in the line chart. I make this appear ymin -0.01, but the 0 is shown on the y-axis as -0 (negative number). Is there also a trick?

I create graphics for weather, rain starts at 0 and summed up. Wind speed is 0 times times higher. Therefore, for my application a clean 0 important.

Thank you for your time for my problem.

Cheers
Toby
Posted by RGraph Support on 5th November 2013
Hi there,

I can't tell what you're saying - try providing a link to an example that shows the issue. There's also another way to do this using chart.scale.specific to specify exactly what gets shown on the Y scale:

www.rgraph.net/fiddle/view/a-filled-line-chart-with-a-specific-scale-that-starts-at-zero



Richard, RGraph Support
Please remember to link to the RGraph website

Help support RGraph - single site license only £99
    www.rgraph.net/license#single-site
Posted by Toby on 5th November 2013
Hello Richard

Thanks for your time.

In this example, give a value of 0, it is not shown.
www.rgraph.net/fiddle/view/a-filled-line-chart-with-a-scale-that-starts-at-zero

I tried it with "outofbounds, true" but it also draws not the value.

What am I doing wrong?

Cheers
Tobias
Posted by RGraph support on 5th November 2013
Hi there,

0 is the default value - and if it's zero it's not shown. Hence you need to set it to a minimal value or alternatively use the chart.scale.specific option.




Richard, RGraph Support
Please remember to link to the RGraph website (or buy an RGraph
license and you don't need to!)

Single developer license just £199:
   www.rgraph.net/license#one-developer
Posted by Toby on 5th November 2013
Hello Richard

Thank you very much for explanations.

Would it be possible for an upcoming version, for example,
chart.axis.defaultvalue or chart.axis.showzero
to create work around this?

Cheers
Tobias
Posted by RGraph support on 5th November 2013
Hi there,

I could add something like chart.scale.zerostart for you similar to the X/Y axis drawing API objects if you wish. If you would like this doing for you as a "license holders customisation" email me at support@rgraph.net.




Richard, RGraph Support
Please remember to link to the RGraph website (or buy an RGraph
license and you don't need to!)

Single developer license just £199:
   www.rgraph.net/license#one-developer

Add a reply




« Back to message list